Skip to main content
VulnerabilityPublished

CVE-2026-116163: Parse Server 9.0.0 before 9.10.5 Authentication Bypass via AuthAdapter Subclasses

Affects parseSource GCVE Database

0
Compare
Authoritative record:CVE-2026-116163· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical : upgrade to 9.10.5 or 8.6.102 as a priority.

Data as of 31 Oct 2026, 00:52 UTC

CVSS 4.0 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.09.1
CNA (VulnCheck)CVSS 3.17.4
Patch
Available – fixed in 9.10.5, 8.6.102
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse to 9.10.5 or 8.6.102.

Affected software

ProductAffectedFixed in
Bitnamiparsepkg:bitnami/parseOther threatsAffected
  • <8.6.102
  • >=9.0.0 <9.10.5
Fixed in
  • 8.6.102
  • 9.10.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should upgrade to Parse Server versions 8.6.102 or 9.10.5 or later to remediate this vulnerability. Applying these official fixes will ensure that the validateSetUp, validateLogin, and validateUpdate methods of custom AuthAdapter subclasses are properly called, preventing authentication bypass.

Description

Parse Server versions before 8.6.102 and from 9.0.0 up to but not including 9.10.5 contain an authentication bypass vulnerability. This occurs because custom AuthAdapter subclasses do not have their validateSetUp, validateLogin, and validateUpdate methods called, causing the system to fall back to a default that accepts any authentication data. This flaw allows attackers to supply arbitrary authentication data to sign up, link identities, log in as existing users, or bypass additional authentication factors.

References

Community reviews

Loading reviews…