Skip to main content
VulnerabilityPublished

CVE-2026-116161: Parse Server 9.0.0 before 9.10.5 LiveQuery Information Disclosure via $or Subscriptions

Affects parseSource GCVE Database

0
Compare
Authoritative record:CVE-2026-116161· Medium 6.0

Not known to be exploited · CVSS 6.0 Medium : upgrade to 9.10.5 or 8.6.103 when convenient.

Data as of 31 Oct 2026, 00:53 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.0
Patch
Available – fixed in 9.10.5, 8.6.103
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse to 9.10.5 or 8.6.103.

Affected software

ProductAffectedFixed in
Bitnamiparsepkg:bitnami/parseOther threatsAffected
  • <8.6.103
  • >=9.0.0 <9.10.5
Fixed in
  • 8.6.103
  • 9.10.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Parse Server to version 8.6.103 or later if using the 8.x branch, or to version 9.10.5 or later if using the 9.x branch. These versions contain the official fix for this vulnerability. No other mitigation is indicated by the vendor advisory.

Description

Parse Server versions before 8.6.103 and from 9.0.0 up to but not including 9.10.5 contain an information disclosure vulnerability in the LiveQuery feature. The issue arises because the subscription hash omits constraints adjacent to a $or operator, causing distinct subscriptions to be grouped incorrectly. This allows authenticated clients using $or queries to receive events intended for other users, including session tokens that could be used for impersonation.

References

Community reviews

Loading reviews…