CVE-2026-116162: Parse Server 9.0.0 before 9.10.5 Privilege Escalation via SMS MFA Login
Affects parseSource GCVE Database
Not known to be exploited · CVSS 2.1 Low : upgrade to 9.10.5 or 8.6.104 when convenient.
Data as of 31 Oct 2026, 00:53 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 2.1 |
|---|
- Patch
- Available – fixed in 9.10.5, 8.6.104
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse to 9.10.5 or 8.6.104.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamiparsepkg:bitnami/parseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied. The issue is fixed in Parse Server versions 8.6.104 and 9.10.5. Users should upgrade to these versions or later to remediate the vulnerability.
Description
Parse Server versions before 8.6.104 and 9.0.0 before 9.10.5 contain a privilege escalation vulnerability in the SMS multi-factor authentication (MFA) login process. The server saves the entire login request with master privileges when issuing an SMS MFA verification code. This allows an SMS MFA-enrolled user to modify master-key-restricted fields on their own account, such as the email-verification flag or values protected by beforeSave triggers.