Skip to main content
CVE-2026-123487VulnerabilityPublished

Parse Server before 8.6.115 and 9.0.0 before 9.10.7-alpha.1 validates user email address format with a regular

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123487· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 9.10.7-alpha.1 soon.

Data as of 6 Nov 2026, 17:02 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.17.5
Patch
Available – fixed in 9.10.7-alpha.1, 8.6.115
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade parse-server to 9.10.7-alpha.1; parse-server to 8.6.115; parse-server to 9.10.7-alpha.1 or 8.6.115.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.10.7-alpha.1
Fixed in
  • 9.10.7-alpha.1
parse-communityparse-serverAffected
  • <8.6.115
Fixed in
  • 8.6.115
npmparse-serverpkg:npm/parse-serverOther threatsAffected
  • >=9.0.0 <9.10.7-alpha.1
  • <8.6.115
Fixed in
  • 9.10.7-alpha.1
  • 8.6.115

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Parse Server versions 8.6.115 and 9.10.7-alpha.1 and later. Users should upgrade to these or later versions to remediate this vulnerability. No other mitigation or workaround is indicated in the provided data.

Description

Parse Server versions before 8.6.115 and 9.0.0 before 9.10.7-alpha.1 contain a vulnerability in the email address validation logic. The validation uses a regular expression with quadratic runtime complexity and no length limit, allowing an attacker to craft a long email address that blocks the Node.js event loop. This results in a denial of service affecting all clients.

References

Community reviews

Loading reviews…