PCRE2 before 10.49, when there is an attacker-controlled regular expression and certain JIT API usage, allows an
Affects pcre2Source GCVE Database
Not known to be exploited · CVSS 7.6 High · fixed in 10.49 : patch pcre2 soon.
Data as of 3 Nov 2026, 22:58 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.49
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 30 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10pcre2pkg:deb/ubuntu/pcre2?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in PCRE2 version 10.49 and later. Users should upgrade to version 10.49 or newer to remediate this vulnerability. No additional mitigation steps are indicated or required beyond applying the official patch.
Description
PCRE2 versions before 10.49 contain a vulnerability where an attacker-controlled regular expression combined with certain JIT API usage can cause an out-of-bounds write with arbitrary data. This flaw can lead to integrity and availability impacts. The vulnerability has a high severity score of 7.6 CVSS v3.1. Multiple specific versions of PCRE2 are affected. No public exploits or known in-the-wild exploitation have been reported as of the publication date.