CVE-2026-86145: pcre2 vulnerabilities
Affects pcre2Source GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.2 High · fixed in 10.21-1ubuntu0.1~esm1 : patch pcre2 soon.
Data as of 4 Nov 2026, 04:01 UTC
- Patch
- Available – fixed in 10.21-1ubuntu0.1~esm1, 10.31-2ubuntu0.1~esm2, 10.34-7ubuntu0.1+esm1 +4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 5 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10pcre2pkg:deb/ubuntu/pcre2?arch=source&distro=stonkingOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and has been released by Ubuntu for all affected versions. Users should apply the security updates provided in Ubuntu Security Notice USN-8974-1. For Ubuntu Pro users, fixes are available via extended security maintenance (ESM). Standard system updates will apply the necessary patches to mitigate these vulnerabilities.
Description
Multiple vulnerabilities were discovered in PCRE2 affecting various Ubuntu LTS and interim releases. These issues include improper memory management, incorrect processing of certain patterns, and exposure of uninitialized data. The vulnerabilities could allow attackers to execute arbitrary code, cause denial of service, or obtain sensitive information. The affected Ubuntu versions range from 16.04 LTS through 26.10. Fixes have been released for all affected versions.
References
- ubuntu.com/security/notices/USN-8974-1 (opens in a new tab)
- ubuntu.com/security/CVE-2026-86145 (opens in a new tab)
- ubuntu.com/security/CVE-2026-89156 (opens in a new tab)
- ubuntu.com/security/CVE-2026-89157 (opens in a new tab)
- ubuntu.com/security/CVE-2026-89158 (opens in a new tab)
- ubuntu.com/security/CVE-2026-89160 (opens in a new tab)
- ubuntu.com/security/CVE-2026-89161 (opens in a new tab)
- ubuntu.com/security/CVE-2026-89162 (opens in a new tab)
- ubuntu.com/security/CVE-2026-103111 (opens in a new tab)