Skip to main content
VulnerabilityPublished

CVE-2026-14330: pipewire security update

Affects pipewireSource GCVE Database

0
Compare
Authoritative record:CVE-2026-14330· Medium 5.5

Not known to be exploited · CVSS 5.5 Medium : upgrade to 0.3.63-7.oe2403sp3 when convenient.

Data as of 29 Oct 2026, 10:47 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.3.63-7.oe2403sp3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade pipewire to 0.3.63-7.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3pipewirepkg:rpm/openEuler/pipewire&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <0.3.63-7.oe2403sp3
Fixed in
  • 0.3.63-7.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in PipeWire version 0.3.63-7.oe2403sp3. Users and administrators should update to this fixed version to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

PipeWire versions prior to 0.3.63-7.oe2403sp3 contain a vulnerability involving multiple unbounded alloca() calls in the PulseAudio protocol server. This flaw allows an attacker with minimal permissions inside a sandboxed environment, such as Flatpak, to escape the sandbox by loading a malicious library via PipeWire's PulseAudio compatibility layer. Successful exploitation can lead to arbitrary code execution outside the sandbox and full compromise of the user's system.

References

Community reviews

Loading reviews…