CVE-2025-43859: Poetry · h11 accepts some malformed Chunked-Encoding bodies
Affects poetrySource GCVE Database
Not known to be exploited · CVSS 9.1 Critical : upgrade to 2.1.2_1 as a priority.
Data as of 30 Oct 2026, 08:29 UTC
- Patch
- Available – fixed in 2.1.2_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade poetry to 2.1.2_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpoetrypkg:brew/poetryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in h11 version 0.15.0 that corrects the chunked encoding parsing to strictly require \r\n as the chunk terminator. Applying this update mitigates the vulnerability. Alternatively, fixing any buggy proxy or reverse proxy that incorrectly parses chunked bodies also mitigates the issue. Since exploitation requires both components to be vulnerable, remediating either side is sufficient.
Description
h11 versions up to 0.14.0 improperly parse HTTP/1.1 chunked transfer encoding by accepting any two bytes as the chunk terminator instead of strictly requiring \r\n. This leniency can cause request smuggling vulnerabilities when combined with a proxy that parses chunked bodies differently. An attacker can craft requests that are interpreted inconsistently by h11 and the proxy, potentially bypassing security controls or causing session key leakage. The issue is fixed in h11 version 0.15.0.
References
- github.com/python-hyper/h11/security/advisories/GHSA-vqfr-h8mv-ghfj (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-43859 (opens in a new tab)
- github.com/python-hyper/h11/commit/114803a29ce50116dc47951c690ad4892b1a36ed (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/h11/PYSEC-2026-348.yaml (opens in a new tab)
- github.com/python-hyper/h11 (opens in a new tab)
- pypi.org/project/h11 (opens in a new tab)