Skip to main content
VulnerabilityPublished

CVE-2026-113726: Poetry · virtualenv activate runs commands from the environment name in zsh with PROMPT_SUBST

Affects poetrySource GCVE Database

0
Compare
Authoritative record:CVE-2026-113726· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 2.5.1_1 or 1.2.2_1 soon.

Data as of 30 Oct 2026, 08:17 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.8
Patch
Available – fixed in 2.5.1_1, 1.2.2_1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade poetry to 2.5.1_1 or 1.2.2_1.

Affected software

ProductAffectedFixed in
Homebrewpoetrypkg:brew/poetryOther threatsAffected
  • >=1.1.0 <1.2.2_1
  • >=1.8.0 <2.5.1_1
Fixed in
  • 1.2.2_1
  • 2.5.1_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Poetry versions 1.2.2_1 and 2.5.1_1 which properly escapes the environment name in the prompt for zsh users. Users should upgrade to these versions or later. As a workaround, users can set the environment variable VIRTUAL_ENV_DISABLE_PROMPT=1 before sourcing activate to prevent modification of PS1, or disable PROMPT_SUBST in zsh by running 'unsetopt prompt_subst' if not needed. Users should also verify environment names before activation to avoid malicious names.

Description

A command injection vulnerability exists in the Poetry virtual environment activation script for zsh users with the PROMPT_SUBST option enabled. The vulnerability arises because the environment name is inserted into the shell prompt (PS1) without proper escaping under zsh, allowing crafted environment names containing command substitution syntax to execute arbitrary commands each time the prompt is drawn. This affects Poetry versions prior to 1.2.2_1 and 2.5.1_1. The issue is fixed in version 1.2.2_1 and 2.5.1_1 by properly escaping special characters in the prompt string.

References

Community reviews

Loading reviews…