CVE-2026-113776: Poetry · virtualenv activation scripts run code from a path that contains a placeholder name
Affects poetrySource GCVE Database
Not known to be exploited · CVSS 7.8 High : upgrade to 2.5.1_1 soon.
Data as of 30 Oct 2026, 08:17 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.8 |
|---|
- Patch
- Available – fixed in 2.5.1_1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade poetry to 2.5.1_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpoetrypkg:brew/poetryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Poetry version 2.5.1_1. Users should upgrade to this version or later. As a workaround, avoid creating virtual environments with paths or prompts containing placeholder names such as __VIRTUAL_NAME__, __VIRTUAL_ENV__, or __VIRTUAL_PROMPT__. Inspect activation scripts before sourcing if they were generated by untrusted sources.
Description
A code injection vulnerability exists in Poetry's virtualenv activation scripts due to improper handling of placeholder names in environment paths or prompts. When a path contains a placeholder name such as __VIRTUAL_NAME__, the activation script may execute arbitrary shell commands during environment activation. This affects versions from 1.8.3_2 up to but not including 2.5.1_1. The issue is fixed in version 2.5.1_1.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-8rjx-v5ww-45pp (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-113776 (opens in a new tab)
- github.com/pypa/virtualenv/commit/602b26623a724827ff171bf11fef4ad186d01f74 (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.2 (opens in a new tab)