CVE-2026-102925: Poetry · virtualenv bash and fish activation scripts execute commands embedded in paths
Affects poetrySource GCVE Database
Not known to be exploited · CVSS 7.8 High : upgrade to 2.5.0 soon.
Data as of 30 Oct 2026, 08:29 UTC
- Patch
- Available – fixed in 2.5.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade poetry to 2.5.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpoetrypkg:brew/poetryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in Poetry version 2.5.0. Users should upgrade to version 2.5.0 or later to remediate the issue. As a workaround, avoid creating or distributing virtual environments with paths containing shell metacharacters such as ', `, $, ;, (, or ). Additionally, inspect activation scripts before sourcing them if they originate from untrusted sources.
Description
Poetry's virtual environment activation scripts for bash, zsh, and fish shells improperly handle paths containing shell metacharacters. This flaw allows embedded commands in such paths to execute when the activation script is sourced. The issue arises from double quoting of shlex-quoted paths, which leads to premature termination of quotes and unquoted shell code execution. This vulnerability affects Poetry versions from 2.2.0 up to but not including 2.5.0 and was fixed in version 2.5.0.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-p58f-9548-mpm2 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-102925 (opens in a new tab)
- github.com/pypa/virtualenv/pull/3252 (opens in a new tab)
- github.com/pypa/virtualenv/commit/4d5a105ec2a2723b8c7f4571bb68f4f71d01e3f6 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/virtualenv/PYSEC-2026-4013.yaml (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.7.13 (opens in a new tab)
- pypi.org/project/virtualenv (opens in a new tab)