Skip to main content
VulnerabilityPublished

CVE-2026-105619: PostgreSQL Anonymizer doesn't mask data accessed thru a security_invoker view

Affects postgresql_anonymizerSource GCVE Database

0
Authoritative record:CVE-2026-105619· Medium 4.8

Not known to be exploited · CVSS 4.8 Medium : upgrade to 3.3.0 when convenient.

Data as of 28 Oct 2026, 19:42 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.3.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade dalibo/postgresql_anonymizer to 3.3.0.

Affected software

ProductAffectedFixed in
GitHubdalibo/postgresql_anonymizerpkg:github/dalibo/postgresql_anonymizerOther threatsAffected
  • <3.3.0
Fixed in
  • 3.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PostgreSQL Anonymizer to version 3.3.0 or later, where this vulnerability is resolved. No other mitigation steps are indicated.

Description

PostgreSQL Anonymizer versions prior to 3.3.0 do not mask data accessed through security_invoker views, potentially exposing sensitive information. This issue is resolved in version 3.3.0 and later.

References

Community reviews

Loading reviews…