CVE-2026-105620: PostgreSQL Anonymizer doesn't mask data returned by a sub-query in a rule
Affects postgresql_anonymizerSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.3.0 when convenient.
Data as of 28 Oct 2026, 19:42 UTC
- Patch
- Available – fixed in 3.3.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab.com/dalibo/postgresql_anonymizer to 3.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Gogitlab.com/dalibo/postgresql_anonymizerpkg:golang/gitlab.com/dalibo/postgresql_anonymizerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade PostgreSQL Anonymizer to version 3.3.0 or later, where this issue is resolved. No other mitigation is required as the fix is available.
Description
PostgreSQL Anonymizer versions prior to 3.3.0 have a vulnerability where data returned by a sub-query in a rule is not properly masked. This could lead to unauthorized exposure of sensitive data. The issue is fixed in version 3.3.0 and later.