Skip to main content
CVE-2026-44338VulnerabilityPublished

PraisonAI ships and generates a legacy API server with authentication disabled by default, allowing unauthenticated

Affects PraisonAISource GCVE Database

0
Authoritative record:CVE-2026-44338· High 7.3

Not known to be exploited · public detection template (Nuclei) · CVSS 7.3 High : upgrade to 4.6.34 soon.

Data as of 27 Oct 2026, 00:58 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.6.34
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade PraisonAI to 4.6.34.

Affected software

ProductAffectedFixed in
PyPIPraisonAIAffected
  • >=2.5.6 <4.6.34
Fixed in
  • 4.6.34

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to PraisonAI version 4.6.34 or later, which includes a fix for this vulnerability by enabling proper authentication on the legacy API server. Until upgraded, avoid deploying the legacy API server or ensure authentication is explicitly enabled and the server is not bound to all network interfaces. Prefer using the newer 'serve agents' command which is safer by default with localhost binding and API key support.

Description

PraisonAI ships a legacy Flask API server with authentication disabled by default, exposing endpoints that allow unauthenticated access to agent metadata and execution of configured workflows. This insecure default affects versions from 2.5.6 up to but not including 4.6.34. The vulnerable server binds to all network interfaces by default, allowing any reachable caller to invoke sensitive API routes without authentication. A fix is available in version 4.6.34.

References

Community reviews

Loading reviews…