Skip to main content
VulnerabilityPublished Updated

CVE-2026-119207: Prior to 6.21.3, pypdf can consume excessive memory when strict mode loads a crafted invalid PDF

Affects pypdfSource GCVE Database

0
Compare
Authoritative record:CVE-2026-119207· High 7.1

Not known to be exploited · CVSS 7.1 High · fixed in 6.21.3 : patch pypdf soon.

Data as of 4 Nov 2026, 05:00 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.07.1
Patch
Available – fixed in 6.21.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10pypdfpkg:deb/ubuntu/pypdf?arch=source&distro=stonkingOther threatsAffected
  • =6.9.2-1
  • =6.9.2-2
Fixed in–
Ubuntu 26.04 LTSpypdfpkg:deb/ubuntu/pypdf?arch=source&distro=resoluteOther threatsAffected
  • =5.4.0-1
  • =6.9.2-1
Fixed in–
Ubuntu 24.04 LTSpypdfpkg:deb/ubuntu/pypdf?arch=source&distro=nobleOther threatsAffected
  • 3.4.1-1 – 4.0.2-1
5 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade pypdf to version 6.21.3 or later where this issue is fixed. No other mitigation is required as the vulnerability is addressed by this official fix.

Description

pypdf versions prior to 6.21.3 have a vulnerability where loading a crafted invalid PDF dictionary in strict mode can cause excessive memory consumption. This occurs because nested parsing failures append repeated exception text to newly raised errors, amplifying small malformed dictionaries into very large error messages. The issue is fixed in version 6.21.3.

References

Community reviews

Loading reviews…