Skip to main content
VulnerabilityPublished Updated

CVE-2026-101917: pyjwt vulnerabilities

Affects pyjwtSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-101917· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium · fixed in 1.3.0-1ubuntu0.1+esm4 : update pyjwt when convenient.

Data as of 27 Oct 2026, 16:13 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.3.0-1ubuntu0.1+esm4, 1.5.3+ds1-1ubuntu0.1+esm4, 1.7.1-2ubuntu2.1+esm4 +4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10pyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=stonkingOther threatsAffected
  • <2.13.0-1ubuntu1.1
Fixed in
  • 2.13.0-1ubuntu1.1
Ubuntu 26.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=resoluteOther threatsAffected
  • <2.10.1-4ubuntu1.3
Fixed in
  • 2.10.1-4ubuntu1.3
Ubuntu 24.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=nobleOther threatsAffected
  • <2.7.0-1ubuntu0.4
Fixed in
  • 2.7.0-1ubuntu0.4
Ubuntu 22.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=jammyOther threatsAffected
  • <2.3.0-1ubuntu0.6
Fixed in
  • 2.3.0-1ubuntu0.6
Ubuntu Pro 20.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=esm-infra/focalOther threatsAffected
  • <1.7.1-2ubuntu2.1+esm4
Fixed in
  • 1.7.1-2ubuntu2.1+esm4
Ubuntu Pro 18.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <1.5.3+ds1-1ubuntu0.1+esm4
Fixed in
  • 1.5.3+ds1-1ubuntu0.1+esm4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should update PyJWT to the patched package versions provided by Ubuntu for their respective releases. Standard system updates or Ubuntu Pro services will apply these fixes. No additional mitigation steps are required beyond applying the official updates.

Description

Multiple vulnerabilities were discovered in PyJWT affecting various Ubuntu LTS releases and 26.10. These include improper handling of unknown key identifiers leading to potential denial of service via request amplification, improper handling of recursively nested JSON payloads causing application failure, malformed RSA key handling causing authentication failures or denial of service, and improper validation of OKP private key components allowing misuse of stolen tokens. Fixes are available in updated package versions for affected Ubuntu releases.

References

Community reviews

Loading reviews…