Skip to main content
CVE-2026-102274VulnerabilityPublished Updated

Pyjwt: From 2.9.0 until 2.14.0, PyJWKSet does not catch the plain ValueError raised for malformed RSA JWK components

Affects pyjwtSource GCVE Database

0
Authoritative record:CVE-2026-102274· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium · fixed in 2.3.0-1ubuntu0.6 : update pyjwt when convenient.

Data as of 27 Oct 2026, 14:29 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.3.0-1ubuntu0.6, 2.7.0-1ubuntu0.4, 2.13.0-1ubuntu1.1 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10pyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=stonkingOther threatsAffected
  • <2.13.0-1ubuntu1.1
Fixed in
  • 2.13.0-1ubuntu1.1
Ubuntu 26.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=resoluteOther threatsAffected
  • <2.10.1-4ubuntu1.3
Fixed in
  • 2.10.1-4ubuntu1.3
Ubuntu 24.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=nobleOther threatsAffected
  • <2.7.0-1ubuntu0.4
Fixed in
  • 2.7.0-1ubuntu0.4
Ubuntu 22.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=jammyOther threatsAffected
  • <2.3.0-1ubuntu0.6
Fixed in
  • 2.3.0-1ubuntu0.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and users should update PyJWT to version 2.14.0 or later. For Ubuntu users, apply the security updates provided in the Ubuntu security notices, specifically upgrading to package versions 2.3.0-1ubuntu0.6, 2.7.0-1ubuntu0.4, 2.10.1-4ubuntu1.3, or 2.13.0-1ubuntu1.1 depending on the Ubuntu release. Standard system updates will apply these fixes.

Description

PyJWT versions from 2.9.0 up to but not including 2.14.0 contain a vulnerability where PyJWKSet does not handle malformed RSA JWK components correctly. A malformed RSA key in a JWK Set causes the entire PyJWKSet construction to abort, potentially leading to authentication failures or denial of service in applications using these versions. This issue is fixed in version 2.14.0.

References

Community reviews

Loading reviews…