From 2.1.0 until 2.15.0, PyJWT OKPAlgorithm.from_jwk
Affects pyjwtSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium · fixed in 2.3.0-1ubuntu0.6 : update pyjwt when convenient.
Data as of 27 Oct 2026, 14:29 UTC
- Patch
- Available – fixed in 2.3.0-1ubuntu0.6, 2.7.0-1ubuntu0.4, 2.13.0-1ubuntu1.1 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10pyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=stonkingOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and users should update PyJWT to version 2.15.0 or later. Ubuntu users should upgrade to the fixed package versions: 2.3.0-1ubuntu0.6, 2.7.0-1ubuntu0.4, 2.10.1-4ubuntu1.3, or 2.13.0-1ubuntu1.1 depending on their distribution. Standard system updates will apply these fixes. No additional mitigation is required if the update is applied.
Description
PyJWT versions from 2.1.0 up to 2.15.0 contain a vulnerability in the OKPAlgorithm.from_jwk function where the private-JWK import path does not verify that the public key component 'x' corresponds to the private key component 'd'. This flaw allows an attacker to misuse a stolen sender-constrained token without possessing the legitimate private key if the integration accepts private key parameters from a proof header. The issue is fixed in version 2.15.0.
References
- ubuntu.com/security/CVE-2026-102275 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-102275 (opens in a new tab)
- github.com/jpadilla/pyjwt/security/advisories/GHSA-x33g-cr3x-6449 (opens in a new tab)
- github.com/jpadilla/pyjwt/commit/3cd9ceec33ced359decbad75b413ad668ae6332c (opens in a new tab)
- github.com/jpadilla/pyjwt/releases/tag/2.15.0 (opens in a new tab)
- ubuntu.com/security/notices/USN-8934-1 (opens in a new tab)