Skip to main content
CVE-2026-102268VulnerabilityPublished Updated

Pyjwt: Prior to 2.14.0, is_pem_format

Affects pyjwtSource GCVE Database

0
Authoritative record:CVE-2026-102268· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 1.5.3+ds1-1ubuntu0.1+esm3 : patch pyjwt as a priority.

Data as of 27 Oct 2026, 14:30 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.5.3+ds1-1ubuntu0.1+esm3, 1.7.1-2ubuntu2.1+esm3, 2.3.0-1ubuntu0.5 +3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10pyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=stonkingOther threatsAffected
  • <2.13.0-1ubuntu1
Fixed in
  • 2.13.0-1ubuntu1
Ubuntu 26.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=resoluteOther threatsAffected
  • <2.10.1-4ubuntu1.2
Fixed in
  • 2.10.1-4ubuntu1.2
Ubuntu 24.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=nobleOther threatsAffected
  • <2.7.0-1ubuntu0.3
Fixed in
  • 2.7.0-1ubuntu0.3
Ubuntu 22.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=jammyOther threatsAffected
  • <2.3.0-1ubuntu0.5
Fixed in
  • 2.3.0-1ubuntu0.5
Ubuntu Pro 20.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=esm-infra/focalOther threatsAffected
  • <1.7.1-2ubuntu2.1+esm3
Fixed in
  • 1.7.1-2ubuntu2.1+esm3
Ubuntu Pro 18.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <1.5.3+ds1-1ubuntu0.1+esm3
Fixed in
  • 1.5.3+ds1-1ubuntu0.1+esm3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix for this vulnerability is available and included in PyJWT version 2.14.0 and later. Users should update to version 2.14.0 or a later patched release. Ubuntu users can apply security updates as detailed in Ubuntu Security Notices USN-8916-1 and USN-8916-2. Standard system updates will apply the necessary patches.

Description

PyJWT versions prior to 2.14.0 contain a vulnerability in the is_pem_format function in jwt/utils.py, which fails to recognize all valid PEM representations accepted by the cryptography loader. This flaw allows an attacker who knows the public key to forge authenticated HMAC tokens by exploiting the incorrect treatment of asymmetric public keys as HMAC secrets. The issue is fixed in version 2.14.0.

References

Community reviews

Loading reviews…