CVE-2026-101918: From 2.0.0a1 until 2.15.0, PyJWT PyJWKClient.get_signing_key_from_jwt is affected because payload
Affects pyjwtSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium · fixed in 1.3.0-1ubuntu0.1+esm4 : update pyjwt when convenient.
Data as of 27 Oct 2026, 14:30 UTC
- Patch
- Available – fixed in 1.3.0-1ubuntu0.1+esm4, 1.5.3+ds1-1ubuntu0.1+esm4, 1.7.1-2ubuntu2.1+esm4 +4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 28 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10pyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=stonkingOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTSpyjwtpkg:deb/ubuntu/pyjwt?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and users should upgrade PyJWT to version 2.15.0 or later. Ubuntu users should apply the security updates provided in USN-8934-1 corresponding to their Ubuntu release. Standard system updates will apply the necessary patches. No additional mitigation is required once patched.
Description
PyJWT versions from 2.0.0a1 up to 2.15.0 contain a vulnerability in the PyJWKClient.get_signing_key_from_jwt function where recursively nested JSON payloads cause a RecursionError that is not properly caught. This can lead to an unhandled exception resulting in an HTTP 500 error, causing a denial of service. The issue is fixed in version 2.15.0.
References
- ubuntu.com/security/CVE-2026-101918 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-101918 (opens in a new tab)
- github.com/jpadilla/pyjwt/security/advisories/GHSA-42vr-xj54-vc7v (opens in a new tab)
- github.com/jpadilla/pyjwt/commit/5fde08a6cf906aa7698de2d6391d88b73006b17b (opens in a new tab)
- github.com/jpadilla/pyjwt/releases/tag/2.15.0 (opens in a new tab)
- ubuntu.com/security/notices/USN-8934-1 (opens in a new tab)