Skip to main content
CVE-2025-3001VulnerabilityPublished Updated

CVE-2025-3001: PyTorch torch.lstm_cell memory corruption

Affects pytorchSource GCVE Database

0

Not known to be exploited : upgrade to 2.7.0 when convenient.

Data as of 26 Oct 2026, 07:57 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.7.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade pytorch to 2.7.0.

Affected software

ProductAffectedFixed in
Bitnamipytorchpkg:bitnami/pytorchOther threatsAffected
  • >=2.6.0 <2.7.0
Fixed in
  • 2.7.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade PyTorch to a fixed version beyond 2.6.0 to remediate the issue. Since the vulnerability requires local access, limiting local user permissions can also reduce risk.

Description

A critical vulnerability in PyTorch 2.6.0 affecting the torch.lstm_cell function allows local attackers to cause memory corruption. The vulnerability requires local access to exploit and has been publicly disclosed. A patch is available to remediate this issue.

References

Community reviews

Loading reviews…