Skip to main content
VulnerabilityPublished

CVE-2026-107472: qt6-qt5compat security update

Affects qt6-qt5compatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-107472· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium : upgrade to 6.5.2-4.oe2403sp1 when convenient.

Data as of 4 Nov 2026, 17:01 UTC

CVSS 4.0 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Qt)CVSS 4.04.3
Patch
Available – fixed in 6.5.2-4.oe2403sp1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U/R:U/RE:L/U:Green

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade qt6-qt5compat to 6.5.2-4.oe2403sp1.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP1qt6-qt5compatpkg:rpm/openEuler/qt6-qt5compat&distro=openEuler-24.03-LTS-SP1Other threatsAffected
  • <6.5.2-4.oe2403sp1
Fixed in
  • 6.5.2-4.oe2403sp1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security fix is available in Qt version 6.5.2-4.oe2403sp1. Users and administrators should update affected Qt installations to this version or later to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

An out-of-bounds read vulnerability exists in the QTextCodec TSCII encoding of the Qt 5 Compatibility APIs module (Qt Core in Qt 5 and earlier). This flaw may cause applications that convert text to the TSCII encoding to read memory outside the input buffer, potentially leading to application crashes or data misinterpretation. The issue affects versions prior to 6.5.2-4.oe2403sp1 and has a medium severity rating with a CVSS score of 6.8. A security fix is available in version 6.5.2-4.oe2403sp1.

References

Community reviews

Loading reviews…