CVE-2026-107472: qt6-qt5compat security update
Affects qt6-qt5compatSource GCVE Database
Not known to be exploited · CVSS 4.3 Medium : upgrade to 6.5.2-4.oe2403sp3 when convenient.
Data as of 4 Nov 2026, 17:01 UTC
Thin evidence
One scorer or none| CNA (Qt) | CVSS 4.0 | 4.3 |
|---|
- Patch
- Available – fixed in 6.5.2-4.oe2403sp3
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U/R:U/RE:L/U:GreenExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade qt6-qt5compat to 6.5.2-4.oe2403sp3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP3qt6-qt5compatpkg:rpm/openEuler/qt6-qt5compat&distro=openEuler-24.03-LTS-SP3Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in qt6-qt5compat version 6.5.2-4.oe2403sp3. Users and administrators should update affected installations to this version or later to remediate the vulnerability. No additional mitigation steps are indicated.
Description
An out-of-bounds read vulnerability exists in the QTextCodec TSCII encoding of the Qt 5 Compatibility APIs module (Qt Core in Qt 5 and earlier). This flaw may cause applications converting text to TSCII encoding to read memory outside the input buffer, potentially leading to crashes or data misinterpretation. The issue affects versions of qt6-qt5compat prior to 6.5.2-4.oe2403sp3. A fix is available in version 6.5.2-4.oe2403sp3.