Skip to main content
CVE-2025-58098VulnerabilityPublished Updated

Red Hat Security Advisory: httpd security update

Affects Red Hat httpdSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2025-58098· High 8.3

Not known to be exploited · CVSS 8.3 High : upgrade Red Hat httpd to 2.4.66 soon.

Data as of 5 Nov 2026, 20:47 UTC

CVSS 3.1 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.66
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade apache/httpd to 2.4.66.

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • <2.4.66
Fixed in
  • 2.4.66

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated httpd packages that address these vulnerabilities. Users should apply the security update promptly by following the instructions in the Red Hat advisory (https://access.redhat.com/articles/11258). No additional mitigation steps are indicated beyond applying the official patch. The vulnerabilities are fixed in the updated packages for Red Hat Enterprise Linux 10 and its Extended Update Support versions.

Description

Red Hat has issued a security advisory for the Apache HTTP Server (httpd) packages addressing three vulnerabilities: a CGI environment variable override (CVE-2025-65082), a mod_userdir+suexec bypass via AllowOverride FileInfo (CVE-2025-66200), and a Server Side Includes issue where the query string is added to the #exec cmd (CVE-2025-58098). These vulnerabilities affect Red Hat Enterprise Linux 10 and its Extended Update Support versions. The update is rated as Important by Red Hat Product Security. No CVSS scores are provided in the advisory. The vulnerabilities are fixed in updated httpd packages available from Red Hat.

References

Community reviews

Loading reviews…