Skip to main content
CVE-2026-93543VulnerabilityPublished Updated

Red Hat Security Advisory: libXi security update

Affects Red Hat libXiSource GCVE Database

0
Compare
Authoritative record:CVE-2026-93543· High 7.4

Not known to be exploited · CVSS 7.4 High : upgrade Red Hat libxi to 1.8.4 soon.

Data as of 29 Oct 2026, 10:10 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.8.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade libXi and x.org/libxi to 1.8.4.

Affected software

ProductAffectedFixed in
x.orglibXiAffected
  • <1.8.4
Fixed in
  • 1.8.4
X.orgx.org/libxipkg:deb/x.org/libxiOther threatsAffected
  • <1.8.4
Fixed in
  • 1.8.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update for libXi in Red Hat Enterprise Linux 10 to address this vulnerability. Users should apply the update as described in the Red Hat advisory (RHSA-2026:91004) and the referenced article (https://access.redhat.com/articles/11258) to remediate the issue. No additional mitigation steps are indicated beyond applying the provided patch.

Description

A denial of service vulnerability exists in the X.Org X11 libXi runtime library due to an out-of-bounds read in the XI2 class parser (CVE-2026-93543). This issue affects Red Hat Enterprise Linux 10 across multiple architectures. Red Hat has released a security update to address this moderate severity flaw.

References

Community reviews

Loading reviews…