Skip to main content
CVE-2025-32414VulnerabilityPublished Updated

Red Hat Security Advisory: libxml2 security update

Affects Red Hat libxml2Source GCVE Database

0
Authoritative record:CVE-2025-32414· Medium 5.6

Not known to be exploited · CVSS 5.6 Medium : upgrade the Debian debian/libxml2 package to 2.14.2 or 2.13.8 when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
5.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.14.2, 2.13.8
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Debian debian/libxml2 package to 2.14.2 or 2.13.8.

Affected software

ProductAffectedFixed in
Debiandebian/libxml2pkg:deb/debian/libxml2Other threatsAffected
  • <2.13.8
  • >=2.14.0 <2.14.2
  • =0
  • =2.14.0
Fixed in
  • 2.13.8
  • 2.14.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update that fixes this vulnerability in libxml2 version 2.9.7-20.el8_10. Users of Red Hat Enterprise Linux 8 should apply this update promptly to mitigate the risk. Detailed update instructions are available in the Red Hat advisory and knowledge base article referenced by Red Hat. No additional mitigation steps are required beyond applying the official patch.

Description

A moderate severity security vulnerability (CVE-2025-32414) has been identified in the libxml2 library used in Red Hat Enterprise Linux 8. The vulnerability is an out-of-bounds read flaw. Red Hat has released an official security update in libxml2 version 2.9.7-20.el8_10 to address this issue. The update is available for multiple architectures including x86_64, s390x, ppc64le, and aarch64. Users of affected Red Hat Enterprise Linux 8 versions should apply the update to mitigate the vulnerability.

References

Community reviews

Loading reviews…