Skip to main content
CVE-2026-42533VulnerabilityPublished Updated

Red Hat Security Advisory: nginx security update

Affects Red Hat nginxSource GCVE Database

0
Compare
Authoritative record:CVE-2026-42533· High 8.1

Not known to be exploited · CVSS 8.1 High · fixed in Red Hat package updates : patch Red Hat nginx soon.

Data as of 2 Nov 2026, 06:29 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 37.0.3.1, 1.31.3, 1.30.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade NGINX to 37.0.3.1 (Plus); 1.31.3 or 1.30.4 (Open Source).

Affected software

ProductAffectedFixed in
F5NGINX PlusAffected
  • >=37.0.0.1 <37.0.3.1
  • >=R33
  • =R36
Fixed in
  • 37.0.3.1
F5NGINX Open SourceAffected
  • >=1.31.2 <1.31.3
Fixed in
  • 1.31.3
F5NGINX Open SourceAffected
  • >=0.9.6 <1.30.4
Fixed in
  • 1.30.4

AI-suggested

Red Hat has released official security updates that fix this vulnerability. Users should apply the provided patches for nginx on Red Hat Enterprise Linux 10 and related distributions as detailed in the Red Hat advisory RHSA-2026:67314. No additional mitigation steps are indicated beyond applying the update.

Description

A security update for nginx addresses an arbitrary code execution vulnerability (CVE-2026-42533) triggered by crafted HTTP requests. This vulnerability affects Red Hat Enterprise Linux 10 and related distributions. The issue allows attackers to execute arbitrary code on affected systems. Red Hat has released patches to fix this vulnerability, and users are advised to apply the update promptly. No public exploit or in-the-wild exploitation has been reported. The advisory rates the impact as Important (high severity).

References

Community reviews

Loading reviews…