Skip to main content
CVE-2026-109089VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Hardened Images RPMs bug fix and enhancement update

Affects Red HatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-109089· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat to 1.8.4 soon.

Data as of 3 Nov 2026, 07:29 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (suse)CVSS 3.17.5
Patch
Available – fixed in 1.8.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade libXi to 1.8.4.

Affected software

ProductAffectedFixed in
X.OrglibXiAffected
  • <1.8.4
Fixed in
  • 1.8.4

AI-suggested

An official patch is available in libXi version 1.8.4-1.hum1 and libXi-devel-1.8.4-1.hum1. Users should apply this update to fully remediate the vulnerability. Until patched, mitigation includes restricting client applications from connecting to remote or untrusted X11 or Xwayland display servers. Additional compensating controls include enabling Address Space Layout Randomization (ASLR), compiling client binaries with Full RELRO and PIE, enabling FORTIFY_SOURCE, running SELinux in enforcing mode, and isolating client applications using Linux namespaces. These measures reduce exploitation impact but do not fix the underlying vulnerability. Applying the official patch is the recommended remediation.

Description

A heap-based buffer overflow vulnerability exists in libXi's handling of DEVICE_ENABLE responses from an X server. A malicious X server can send an oversized DEVICE_ENABLE reply to a client application, potentially causing arbitrary code execution or a denial of service. The vulnerability primarily affects client applications connecting to remote or untrusted X11 or Xwayland display servers. In typical Red Hat Enterprise Linux environments with trusted local display servers, the risk is substantially limited. An update to libXi version 1.8.4-1.hum1 addresses this issue.

References

Community reviews

Loading reviews…