Skip to main content
CVE-2026-116591VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Hardened Images RPMs Security Update

Affects Red HatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-116591· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade Red Hat to 1.20.2 soon.

Data as of 30 Oct 2026, 01:48 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.08.7
Patch
Available – fixed in 1.20.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade compress to 1.20.2.

Affected software

ProductAffectedFixed in
klauspostcompressAffected
  • <1.20.2
Fixed in
  • 1.20.2

AI-suggested

Red Hat has released updated RPM packages (spire1.14-1.14.9-0.3.hum1 and related) that fix this vulnerability. Users should apply these updates to remediate the issue. Additionally, filtering or rejecting untrusted Zstandard compressed payloads at ingress proxies or restricting decompression endpoints to authenticated, trusted clients can mitigate risk. No direct configuration-level workaround exists within the library itself.

Description

A vulnerability (CVE-2026-116591) exists in the klauspost compress library's Zstandard (zstd) decompression implementation used in Red Hat Hardened Images RPMs. The flaw is an integer handling error in the decompression logic that causes an out-of-bounds read and an unhandled panic, leading to application crashes and denial of service. This affects applications decompressing untrusted inputs. The vulnerability is addressed in updated RPM packages provided by Red Hat.

References

Community reviews

Loading reviews…