Skip to main content
CVE-2026-123609VulnerabilityPublished

Rustls before 0.23.46 and 0.24.0-dev.1 before 0.24.0-dev.2 contains an information disclosure vulnerability where

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123609· Medium 4.1

Not known to be exploited · CVSS 4.1 Medium : upgrade to 0.24.0-dev.2 or 0.23.46 when convenient.

Data as of 8 Nov 2026, 06:21 UTC

CVSS 4.0 base score
4.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.04.1
CNA (VulnCheck)CVSS 3.14.0
Patch
Available – fixed in 0.24.0-dev.2, 0.23.46
CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade rustls to 0.24.0-dev.2 or 0.23.46.

Affected software

ProductAffectedFixed in
rustlsrustlsAffected
  • >=0.24.0-dev.1 <0.24.0-dev.2
Fixed in
  • 0.24.0-dev.2
rustlsrustlsAffected
  • <0.23.46
Fixed in
  • 0.23.46
crates.iorustlspkg:cargo/rustlsOther threatsAffected
  • <0.23.46
  • >=0.24.0-dev.1 <0.24.0-dev.2
Fixed in
  • 0.23.46
  • 0.24.0-dev.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Rustls to version 0.23.46 or later, or to 0.24.0-dev.2 or later, where this issue is fixed. Avoid logging client session values in custom ClientSessionStore implementations until the update is applied.

Description

Rustls versions before 0.23.46 and 0.24.0-dev.1 before 0.24.0-dev.2 have an information disclosure vulnerability. The issue arises from the Debug formatting of client session values, which can expose secret key material. Specifically, custom ClientSessionStore implementations that log Tls12ClientSessionValue or Tls13ClientSessionValue may leak TLS 1.2 master secrets or TLS 1.3 resumption PSKs to anyone with access to the logs.

References

Community reviews

Loading reviews…