Skip to main content
CVE-2025-13601VulnerabilityPublished Updated

SUSE · Security update for glib2

Affects SUSESource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2025-13601· High 7.7

Not known to be exploited · CVSS 7.7 High · fixed in Red Hat package updates : patch the Red Hat redhat/glib package soon.

Data as of 6 Nov 2026, 14:17 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.7
Patch
Available – fixed in 2.86.3, 10.2, 9.8
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade glib to 2.86.3; the Red Hat redhat/glib package to 10.2 or 9.8.

Affected software

ProductAffectedFixed in
glibAffected
  • <2.86.3
Fixed in
  • 2.86.3
Red Hatredhat/glibpkg:rpm/redhat/glibOther threatsAffected
  • =0
  • >=9.0 <9.8
  • >=10.0 <10.2
Fixed in
  • 9.8
  • 10.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade glib2 to version 2.84.4 or later to apply the official fixes for these vulnerabilities. No additional mitigation is required as the update addresses all identified issues.

Description

This security update for glib2 addresses multiple vulnerabilities including integer overflows, buffer underflows, and heap-based buffer overflows in various functions such as GIO escape_byte_string(), GVariant parser, and g_escape_uri_string(). These flaws can lead to denial-of-service, crashes, or potential code execution. Additionally, an integer overflow when creating temporary files may allow path traversal or exposure of sensitive content. The update also fixes several memory leaks and error handling issues. The update is provided in version 2.84.4.

References

Community reviews

Loading reviews…