Skip to main content
CVE-2025-14179VulnerabilityPublished Updated

SUSE php8 · Security update for php8

Affects SUSE php8Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2025-14179· High 7.4

Public exploit available · CVSS 7.4 High : upgrade the SUSE suse/php8 package to 8.4.21 as a priority.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 4.0 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.4.21
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P/AU:Y/RE:M/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade the SUSE suse/php8 package to 8.4.21.

Affected software

ProductAffectedFixed in
SUSEsuse/php8pkg:rpm/suse/php8Other threatsAffected
  • <8.4.21
Fixed in
  • 8.4.21

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available that addresses all listed vulnerabilities by upgrading PHP to version 8.4.21. Users should apply this official fix promptly to mitigate the risks. No additional vendor advisories indicate alternative mitigations or that no action is required.

Description

This security update for PHP 8 addresses multiple vulnerabilities including SQL injection, out-of-bounds reads, use-after-free, cross-site scripting (XSS), denial of service, memory corruption, information disclosure, and infinite loops. The update also includes an upgrade to PHP version 8.4.21. These issues affect various components such as the PDO Firebird driver, mbstring encoding functions, SOAP handling, PHP-FPM status page, ctype functions, and XML processing.

References

Community reviews

Loading reviews…