Skip to main content
VulnerabilityPublished Updated

CVE-2026-6951: simple-git is vulnerable to Remote Code Execution

Affects simple-gitSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-6951· Critical 9.2

Public exploit available · CVSS 9.2 Critical : upgrade to 3.36.0 as a priority.

Data as of 27 Oct 2026, 00:07 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.36.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade simple-git to 3.36.0.

Affected software

ProductAffectedFixed in
npmsimple-gitAffected
  • <3.36.0
Fixed in
  • 3.36.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Versions of the package simple-git before 3.36.0 are vulnerable to Remote Code Execution (RCE) due to an incomplete fix for [CVE-2022-25912](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-3112221) that blocks the -c option but not the equivalent --config form. If untrusted input can reach the options argument passed to simple-git, an attacker may still achieve remote code execution by enabling protocol.ext.allow=always and using an ext:: clone source.

References

Community reviews

Loading reviews…