Skip to main content
VulnerabilityPublished Updated

CVE-2026-116590: snappy-java is a Java port of the snappy, a fast C++ compresser/decompresser developed by Google

Affects snappy-javaSource GCVE Database

0
Authoritative record:CVE-2026-116590· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium · fixed in 1.1.10.9 : update snappy-java when convenient.

Data as of 28 Oct 2026, 22:42 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.1.10.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10snappy-javapkg:deb/ubuntu/snappy-java?arch=source&distro=stonkingOther threatsAffected
  • =1.1.10.8-1
Fixed in–
Ubuntu 26.04 LTSsnappy-javapkg:deb/ubuntu/snappy-java?arch=source&distro=resoluteOther threatsAffected
  • =1.1.10.7-1
  • =1.1.10.8-1
Fixed in–
Ubuntu 24.04 LTSsnappy-javapkg:deb/ubuntu/snappy-java?arch=source&distro=nobleOther threatsAffected
  • =1.1.8.3-1
  • =1.1.10.5-1
  • =1.1.10.5-1build1
Fixed in–
Ubuntu 22.04 LTSsnappy-javapkg:deb/ubuntu/snappy-java?arch=source&distro=jammyOther threatsAffected
  • =1.1.8.3-1
Fixed in–
Ubuntu 20.04 LTSsnappy-javapkg:deb/ubuntu/snappy-java?arch=source&distro=focalOther threatsAffected
  • =1.1.7.2-1
  • =1.1.7.3-1
  • =1.1.7.3-1build1
Fixed in–
Ubuntu 18.04 LTSsnappy-javapkg:deb/ubuntu/snappy-java?arch=source&distro=bionicOther threatsAffected
  • =1.1.4-1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to snappy-java version 1.1.10.9 or later, where this vulnerability is fixed. No other mitigations are indicated.

Description

A vulnerability in snappy-java prior to version 1.1.10.9 allows out-of-bounds memory access due to improper validation of array ranges passed to native memcpy. This can cause JVM crashes. The issue is fixed in version 1.1.10.9.

References

Community reviews

Loading reviews…