Skip to main content
CVE-2026-121881VulnerabilityPublished

Posit Software, PBC Posit Workbench · SQL Injection Vulnerability

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-121881· Medium 5.7

Public exploit available · CVSS 5.7 Medium : upgrade to 2026.08.0 as a priority.

Data as of 6 Nov 2026, 19:19 UTC

CVSS 4.0 base score
5.7Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (POSIT)CVSS 4.05.7
Patch
Available – fixed in 2026.08.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P/AU:Y/R:A/V:C/RE:M/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade Posit Workbench to 2026.08.0.

Affected software

ProductAffectedFixed in
Posit Software, PBCPosit WorkbenchAffected
  • <2026.08.0
Fixed in
  • 2026.08.0

AI-suggested

A fix is available in Posit Workbench version 2026.08.0 and later. Users should upgrade to this version or later to remediate the vulnerability. No other mitigation or workaround is documented. Since this is not a cloud service, remediation depends on applying the official patch.

Description

An SQL injection vulnerability exists in the get_last_seen code-server session-state RPC in Posit Workbench versions before 2026.08.0. Authenticated users can exploit this flaw to read arbitrary data from the Workbench database using the sessionIds parameter. Exploitation requires a valid authenticated session but does not require administrative privileges. The vulnerability is limited to unauthorized disclosure of database contents.

References

Community reviews

Loading reviews…