Skip to main content
CVE-2026-123859VulnerabilityPublished

When identifier escaping is disabled through a non-default configuration, the write_pandas() data-loading

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123859· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 4.8.1 soon.

Data as of 6 Nov 2026, 19:04 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (SNOWFLAKE)CVSS 3.18.1
Patch
Available – fixed in 4.8.1, 5.2.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade Snowflake Connector for Python to 4.8.1; Snowflake Connector for Python (Universal Core) to 5.2.0; snowflake-connector-python to 5.2.0 or 4.8.1.

Affected software

ProductAffectedFixed in
Snowflake Connector for Pythonsnowflake-connector-pythonAffected
  • >=2.3.4 <4.8.1
Fixed in
  • 4.8.1
Snowflake Connector for Python (Universal Core)snowflake-connector-pythonAffected
  • >=5.0.0b1 <5.2.0
Fixed in
  • 5.2.0
PyPIsnowflake-connector-pythonpkg:pypi/snowflake-connector-pythonOther threatsAffected
  • >=2.3.4 <4.8.1
  • >=5.0.0b1 <5.2.0
Fixed in
  • 4.8.1
  • 5.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to Snowflake Connector for Python version 4.8.1 or later, and Snowflake Connector for Python (Universal Core) version 5.2.0 or later to remediate this vulnerability. Manual upgrade is required. Until patched, ensure that identifier escaping is enabled or avoid passing untrusted column names to the write_pandas() function.

Description

A SQL injection vulnerability exists in the write_pandas() data-loading functionality of the Snowflake Connector for Python and Snowflake Connector for Python (Universal Core) when identifier escaping is disabled via a non-default configuration. This flaw allows crafted DataFrame column names to be included unescaped in generated SQL statements, enabling an attacker to append additional SQL commands. Exploitation requires attacker-controlled column names passed to this function. The vulnerability can lead to unauthorized reading, modification, or deletion of data accessible to the application's Snowflake role. Fixed versions are 4.8.1 for Snowflake Connector for Python and 5.2.0 for the Universal Core variant.

References

Community reviews

Loading reviews…