SQLite before 3.54.0 built with FTS5 contains a heap buffer overflow in fts5DoSecureDelete() that allows attackers to
Affects sqliteSource GCVE Database
Not known to be exploited · CVSS 8.5 High · fixed in 3.54.0 : patch sqlite soon.
Data as of 4 Nov 2026, 10:58 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.5 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.8 |
| CNA | CVSS 4.0 | 8.5 |
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.54.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10sqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSsqlitepkg:deb/ubuntu/sqlite?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version of SQLite is available starting from 3.54.0. Users should upgrade to version 3.54.0 or later to remediate this vulnerability. Until patched, disabling the secure-delete feature when working with untrusted FTS5 indexes may reduce risk, but upgrading is strongly recommended.
Description
SQLite versions before 3.54.0 built with the FTS5 extension contain a heap buffer overflow vulnerability in the fts5DoSecureDelete() function. This flaw allows attackers to write beyond the leaf page buffer by supplying a database file with a corrupted FTS5 index. When secure-delete is enabled and such an index is deleted, heap memory corruption occurs, potentially crashing the application.
References
- ubuntu.com/security/CVE-2026-119374 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-119374 (opens in a new tab)
- sqlite.org/src/info/9cd4f9e920 (opens in a new tab)
- abraxaslabs.tech/research/sqlite-fts5-securedel (opens in a new tab)
- github.com/sqlite/sqlite (opens in a new tab)
- github.com/sqlite/sqlite/blob/version-3.53.4/ext/fts5/fts5_index.c (opens in a new tab)
- github.com/sqlite/sqlite/commit/d9de6eedbe918c074c7556400fa21df5960704d9 (opens in a new tab)
- sqlite.org/releaselog/3_54_0.html (opens in a new tab)
- vulncheck.com/advisories/sqlite-before-3.54.0-heap-buffer-overflow-via-fts5-fts5dosecuredelete (opens in a new tab)