Skip to main content
CVE-2026-119373VulnerabilityPublished Updated

SQLite before 3.54.0 built with FTS5 contains a heap buffer overflow in fts5MergeRowidLists() that undersizes the

Affects sqliteSource GCVE Database

0
Compare
Authoritative record:CVE-2026-119373· High 8.5

Not known to be exploited · CVSS 8.5 High · fixed in 3.54.0 : patch sqlite soon.

Data as of 4 Nov 2026, 10:58 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.5
CNA (VulnCheck)CVSS 3.17.8
CNACVSS 4.08.5
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.54.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10sqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=stonkingOther threatsAffected
  • =3.46.1-9
  • =3.53.4-2
Fixed in–
Ubuntu 26.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=resoluteOther threatsAffected
  • 3.46.1-8 – 3.46.1-9ubuntu0.3
5 affected builds
Fixed in–
Ubuntu 24.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=nobleOther threatsAffected
  • 3.42.0-1 – 3.45.1-1ubuntu2.9
15 affected builds
Fixed in–
Ubuntu 22.04 LTSsqlitepkg:deb/ubuntu/sqlite?arch=source&distro=jammyOther threatsAffected
  • =2.8.17-15fakesync1build1
Fixed in–
Ubuntu 22.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=jammyOther threatsAffected
  • 3.35.5-1 – 3.37.2-2ubuntu0.8
10 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=esm-infra/focalOther threatsAffected
  • 3.29.0-2 – 3.31.1-4ubuntu0.7+esm2
15 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in SQLite version 3.54.0 and later. Users should upgrade to version 3.54.0 or newer to remediate this vulnerability. No vendor advisory content was provided to indicate alternative mitigations or that no action is required.

Description

SQLite versions before 3.54.0 built with FTS5 contain a heap buffer overflow vulnerability in the fts5MergeRowidLists() function. This flaw occurs when merging detail=none prefix doclists, undersizing the output buffer. An attacker able to insert negative rowids into a detail=none FTS5 table and execute a prefix MATCH query can exploit this to corrupt heap memory and crash the process.

References

Community reviews

Loading reviews…