SQLite before 3.54.0 contains a stack exhaustion vulnerability that allows attackers to bypass the
Affects sqliteSource GCVE Database
Not known to be exploited · CVSS 6.8 Medium · fixed in 3.54.0 : update sqlite when convenient.
Data as of 4 Nov 2026, 10:58 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.8 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.5 |
| CNA | CVSS 4.0 | 6.8 |
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.54.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10sqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSsqlitepkg:deb/ubuntu/sqlite?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in SQLite version 3.54.0 and later. Users should upgrade to version 3.54.0 or newer to remediate this vulnerability. No other specific mitigations are indicated.
Description
SQLite versions before 3.54.0 have a stack exhaustion vulnerability that allows attackers to bypass the SQLITE_LIMIT_EXPR_DEPTH nesting limit. This occurs because common table expressions (CTEs) are not counted against this limit, enabling an attacker to supply a WITH clause chaining tens of thousands of CTEs. This causes unbounded recursion in the selectExpander() function, leading to a process crash.
References
- ubuntu.com/security/CVE-2026-119371 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-119371 (opens in a new tab)
- sqlite.org/bugs/info/2026-10-04T04:58:58Z (opens in a new tab)
- sqlite.org/src/info/f54730871303e655 (opens in a new tab)
- abraxaslabs.tech/research/sqlite-cte-nest (opens in a new tab)
- github.com/sqlite/sqlite (opens in a new tab)
- github.com/sqlite/sqlite/blob/version-3.53.4/src/select.c (opens in a new tab)
- github.com/sqlite/sqlite/commit/e6ff280c839fdfc7418fd5add12e8f32702a17fb (opens in a new tab)
- sqlite.org/releaselog/3_54_0.html (opens in a new tab)
- vulncheck.com/advisories/sqlite-before-3.54.0-stack-exhaustion-via-cte-chain-in-selectexpander (opens in a new tab)