SQLite before 3.54.0 contains an information disclosure vulnerability that allows attackers to read uninitialized
Affects sqliteSource GCVE Database
Not known to be exploited · CVSS 6.8 Medium · fixed in 3.54.0 : update sqlite when convenient.
Data as of 4 Nov 2026, 10:58 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.8 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.5 |
| CNA | CVSS 4.0 | 6.8 |
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.54.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10sqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSsqlitepkg:deb/ubuntu/sqlite?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in SQLite version 3.54.0 and later. Users and administrators should upgrade to version 3.54.0 or newer to remediate this vulnerability. Until upgraded, avoid processing untrusted WAL files with undersized page sizes.
Description
SQLite versions before 3.54.0 have an information disclosure vulnerability that allows attackers to read uninitialized page-cache memory. This occurs when an attacker supplies a WAL file with an undersized page size, causing queries like substr() to return stale bytes. These stale bytes can disclose data from other table rows and internal pointers.
References
- ubuntu.com/security/CVE-2026-119375 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-119375 (opens in a new tab)
- sqlite.org/bugs/info/2026-08-17T15:54:41Z (opens in a new tab)
- sqlite.org/src/info/f9b4ee369557c36c (opens in a new tab)
- abraxaslabs.tech/research/sqlite-wal-pagesize (opens in a new tab)
- github.com/sqlite/sqlite (opens in a new tab)
- github.com/sqlite/sqlite/blob/version-3.53.4/src/wal.c (opens in a new tab)
- github.com/sqlite/sqlite/commit/e5bf119821f25be1d7f10ef0a2edbe175289166e (opens in a new tab)
- sqlite.org/releaselog/3_54_0.html (opens in a new tab)
- vulncheck.com/advisories/sqlite-before-3.54.0-information-disclosure-via-wal-page-size-mismatch (opens in a new tab)