Skip to main content
VulnerabilityPublished

Steamworks game clients/servers using P2P authentication vulnerable to denial of service

Affects steamworksSource GCVE Database

0

CVSS 6.3 Medium : upgrade to 0.13.1 when convenient.

Data as of 27 Oct 2026, 01:12 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.13.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

What to do

Upgrade steamworks to 0.13.1.

Affected software

ProductAffectedFixed in
crates.iosteamworksAffected
  • <0.13.1
Fixed in
  • 0.13.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected Steamworks game clients and servers to version 0.13.1 or later, where the vulnerability has been fixed. Since a patch is available, applying this official fix is the recommended remediation. No additional mitigation actions are indicated by the vendor advisory.

Description

A denial of service vulnerability exists in Steamworks game clients and servers using P2P authentication. When processing the ValidateAuthTicketResponse_t callback, if the m_eAuthSessionResponse field is set to k_EAuthSessionResponseAuthTicketNetworkIdentityFailure, the system panics. This occurs if a malicious client sends an authentication ticket with a mismatched network identity, causing the game client or server to crash or become unavailable. The issue affects versions prior to 0.13.1 and has been fixed in version 0.13.1.

References

Community reviews

Loading reviews…