Skip to main content
VulnerabilityPublished Updated

CVE-2026-35569: apostrophe · Stored XSS

Affects apostropheSource GCVE Database

0
Authoritative record:CVE-2026-35569· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 4.29.0 soon.

Data as of 27 Oct 2026, 00:30 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.29.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade apostrophe to 4.29.0.

Affected software

ProductAffectedFixed in
npmapostropheAffected
  • <4.29.0
Fixed in
  • 4.29.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security patch is available and included in ApostropheCMS version 4.29.0. Users should upgrade to version 4.29.0 or later to remediate this vulnerability. No additional mitigations are necessary once the patch is applied.

Description

A stored cross-site scripting (XSS) vulnerability exists in ApostropheCMS versions prior to 4.29.0 in SEO-related fields such as SEO Title and Meta Description. This flaw allows injection of arbitrary JavaScript into HTML contexts including <title>, <meta> attributes, and JSON-LD structured data. Exploitation enables execution of scripts in authenticated admin users' browsers, permitting authenticated API requests and exfiltration of sensitive user data. The vulnerability is patched in version 4.29.0.

References

Community reviews

Loading reviews…