Skip to main content
CVE-2025-34080VulnerabilityPublished Updated

The Contec Co.,Ltd. CONPROSYS HMI System (CHS) is vulnerable to Cross-Site Scripting (XSS) in the getqsetting.php

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-34080· Medium 5.1

Not known to be exploited · CVSS 5.1 Medium · fixed in 3.7.7 : update affected systems when convenient.

Data as of 4 Nov 2026, 17:52 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.7.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

AI-suggested

A fixed version 3.7.7 or later is implied but not explicitly confirmed by a patch link or vendor advisory. Since the affected versions are prior to 3.7.7, upgrading to version 3.7.7 or later is recommended if available. Patch status is not explicitly confirmed in the provided data; therefore, check the vendor advisory for current remediation guidance.

Description

The Contec Co.,Ltd. CONPROSYS HMI System (CHS) before version 3.7.7 is vulnerable to a reflected Cross-Site Scripting (XSS) flaw in the getqsetting.php functionality. This vulnerability could allow an attacker to execute scripts in the victim's browser when interacting with the affected functionality. The issue has a medium severity rating with a CVSS score of 6.1.

References

Community reviews

Loading reviews…