UnrealIRCd · Labeled-response Module
Source GCVE Database
Not known to be exploited · CVSS 8.6 High : upgrade to 6.2.7.1 soon.
Data as of 8 Nov 2026, 06:20 UTC
Thin evidence
One scorer or none| CNA (mitre) | CVSS 3.1 | 8.6 |
|---|
- Patch
- Available – fixed in 6.2.7.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade UnrealIRCd to 6.2.7.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| UnrealIRCdUnrealIRCd | Affected
| Fixed in
|
GitHubUnrealIRCdpkg:github/UnrealIRCdOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in UnrealIRCd version 6.2.7.1 and later. Users should upgrade to version 6.2.7.1 or newer to remediate this vulnerability. Until upgrading, network administrators should consider limiting the number of linked servers or monitoring for suspicious server-to-server commands if feasible.
Description
UnrealIRCd versions 6.0.0 up to but not including 6.2.7.1 contain a vulnerability in the labeled-response module where the IRCv3 "label" message tag is not properly escaped. This flaw allows any user on a network with two or more linked servers to inject server-to-server commands that execute with server authority.