Skip to main content
CVE-2025-12118VulnerabilityPublished

The Schema Scalpel plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the post title in all

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-12118· Medium 6.4

Not known to be exploited · CVSS 6.4 Medium · fixed in 1.6.2 : update affected systems when convenient.

Data as of 29 Oct 2026, 23:38 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.6.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

AI-suggested

Since the vulnerability requires authenticated access at Contributor level or above, restricting user permissions can reduce risk. If you cannot patch yet, avoid granting Contributor or higher privileges to untrusted users and consider removing or disabling the Schema Scalpel plugin if possible.

Description

The Schema Scalpel WordPress plugin versions up to and including 1.6.1 contain a stored cross-site scripting (XSS) vulnerability via the post title. This vulnerability arises from insufficient input sanitization and output escaping when user-supplied data is embedded into JSON-LD schema markup. Authenticated users with Contributor-level permissions or higher can exploit this to inject malicious scripts that execute when other users view the affected pages.

References

Community reviews

Loading reviews…