Thelia before 3.2.0 contains a cross-site request forgery vulnerability in the back office that allows attackers to
Affects theliaSource GCVE Database
Not known to be exploited · CVSS 5.9 Medium : upgrade to 3.2.0 when convenient.
Data as of 31 Oct 2026, 19:08 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 5.9 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.9 |
- Patch
- Available – fixed in 3.2.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade thelia/thelia to 3.2.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubthelia/theliapkg:github/thelia/theliaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Thelia version 3.2.0 and later. Users should upgrade to version 3.2.0 or above to remediate this vulnerability. No other mitigation guidance is provided, and no vendor advisory content is available to indicate alternative mitigations or that no action is required.
Description
Thelia versions before 3.2.0 have a cross-site request forgery (CSRF) vulnerability in the back office. This vulnerability arises because per-session CSRF tokens leak via URL query strings, allowing attackers to reuse these tokens or exploit unprotected actions. Specifically, attackers can target the setToggleVisibilityAction and updatePositionAction to perform unauthorized administrative actions such as deleting, hiding, or reordering catalogue and configuration objects.
References
- github.com/thelia/thelia/security/advisories/GHSA-cfvv-2jvw-x2hp (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-120206 (opens in a new tab)
- github.com/thelia-templates/default-twig/commit/a9647682572de056ba258a2d4d53e42f5b591b84 (opens in a new tab)
- github.com/thelia/thelia/commit/55a7156e552d0b8145309b10175d13ecc1187433 (opens in a new tab)
- github.com/thelia/thelia/blob/3.1.6/core/lib/Thelia/Controller/Admin/AbstractCrudController.php (opens in a new tab)
- github.com/thelia/thelia/releases/tag/3.2.0 (opens in a new tab)
- vulncheck.com/advisories/thelia-before-3.2.0-back-office-csrf-via-url-token-and-unprotected-actions (opens in a new tab)