Skip to main content
CVE-2026-59083VulnerabilityPublished Updated

Tomcat6: Improper Handling of URL Encoding (Hex Encoding) vulnerability in Apache Tomcat's rewrite valve allowed

Affects tomcat6Source GCVE Database

0
Compare
Authoritative record:CVE-2026-59083· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 11.0.24 : patch tomcat6 as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.0.24
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=stonkingOther threatsAffected
  • 10.1.40-1ubuntu1 – 10.1.57~us1-0ubuntu1
7 affected builds
Fixed in–
Ubuntu 26.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=stonkingOther threatsAffected
  • 11.0.18-1 – 11.0.24-1ubuntu1
5 affected builds
Fixed in–
Ubuntu 26.10tomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=stonkingOther threatsAffected
  • =9.0.115-1
  • =9.0.115-1ubuntu1
  • =9.0.118-1
Fixed in–
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=resoluteOther threatsAffected
  • =10.1.40-1ubuntu1
  • =10.1.40-1ubuntu1.26.04.1
  • =10.1.55-1ubuntu2~26.04.1
Fixed in–
Ubuntu 26.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=resoluteOther threatsAffected
  • 9.0.95-1ubuntu1 – 9.0.118-1~26.04.1
5 affected builds
Fixed in–
Ubuntu 26.04 LTStomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=resoluteOther threatsAffected
  • 11.0.6-1 – 11.0.22-2ubuntu2~26.04.1
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache Tomcat versions to 11.0.24, 10.1.57, or 9.0.120, which contain fixes for this vulnerability. No other mitigation or temporary workaround is indicated. Applying these official fixes fully addresses the issue.

Description

An improper handling of URL encoding (hex encoding) vulnerability in Apache Tomcat's rewrite valve allows security constraint bypass in certain configurations. This affects Apache Tomcat versions from 11.0.0-M1 through 11.0.23, 10.1.0-M1 through 10.1.56, 9.0.0-M1 through 9.0.119, and 8.5.0 through 8.5.100. The issue is fixed in versions 11.0.24, 10.1.57, and 9.0.120. The vulnerability has a critical severity with a CVSS score of 9.1.

References

Community reviews

Loading reviews…