CVE-2024-25176: LuaJIT through 2.1 and OpenRusty luajit2 before v2.1-20240626 have a stack-buffer-overflow in
Affects luajitSource GCVE Database
Not known to be exploited · CVSS 9.8 Critical · fixed in 2.1.0~beta3+dfsg-5.1ubuntu0.18.04.1~esm1 : patch luajit as a priority.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.1.0~beta3+dfsg-5.1ubuntu0.18.04.1~esm1, 2.1.0~beta3+dfsg-5.1ubuntu0.20.04.1~esm1, 2.1.0~beta3+dfsg-6ubuntu0.1 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10luajitpkg:deb/ubuntu/luajit?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSluajitpkg:deb/ubuntu/luajit?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10luajitpkg:deb/ubuntu/luajit?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSluajitpkg:deb/ubuntu/luajit?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSluajitpkg:deb/ubuntu/luajit?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSluajitpkg:deb/ubuntu/luajit?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
LuaJIT through 2.1 and OpenRusty luajit2 before v2.1-20240626 have a stack-buffer-overflow in lj_strfmt_wfnum in lj_strfmt_num.c.
References
- ubuntu.com/security/CVE-2024-25176 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-25176 (opens in a new tab)
- gist.github.com/pwnhacker0x18/cd75d01fc7c9b6c85c183fbe5353d276 (opens in a new tab)
- github.com/LuaJIT/LuaJIT/commit/343ce0edaf3906a62022936175b2f5410024cbfc (opens in a new tab)
- github.com/LuaJIT/LuaJIT/issues/1149 (opens in a new tab)
- ubuntu.com/security/notices/USN-8544-1 (opens in a new tab)