Skip to main content
VulnerabilityPublished

CVE-2026-87018: undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation

Affects undiciSource GCVE Database

0

Not known to be exploited · CVSS 7.5 High : upgrade to 6.29.1 soon.

Data as of 27 Oct 2026, 20:28 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.29.1, 7.30.1, 8.12.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade undici to 6.29.1; undici to 7.30.1; undici to 8.12.2.

Affected software

ProductAffectedFixed in
npmundiciAffected
  • >=4.2.1 <6.29.1
Fixed in
  • 6.29.1
npmundiciAffected
  • >=7.0.0 <7.30.1
Fixed in
  • 7.30.1
npmundiciAffected
  • >=8.0.0 <8.12.2
Fixed in
  • 8.12.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade undici to version 6.29.1, 7.30.1, or 8.12.2 to apply the official fix. Alternatively, restrict outbound connections to TLS 1.3 by configuring the client or agent with `connect: { minVersion: 'TLSv1.3', maxVersion: 'TLSv1.3' }` to prevent renegotiation when the target endpoints support TLS 1.3.

Description

undici is vulnerable to a denial of service condition triggered by a TLS 1.2 server-initiated renegotiation presenting a different, valid but hostname-mismatched certificate. This causes an uncaught assertion error that crashes the Node.js client process, affecting both HTTP/1.1 and HTTP/2. Only TLS 1.2 is impacted, as TLS 1.3 does not support renegotiation. The issue is fixed in undici versions 6.29.1, 7.30.1, and 8.12.2. Mitigation includes upgrading to these versions or restricting connections to TLS 1.3 to prevent renegotiation.

References

Community reviews

Loading reviews…