CVE-2026-87029: undici vulnerable to Denial of Service via unhandled exception in the decompress interceptor
Affects undiciSource GCVE Database
Not known to be exploited · CVSS 5.9 Medium : upgrade to 7.30.1 when convenient.
Data as of 27 Oct 2026, 20:30 UTC
- Patch
- Available – fixed in 7.30.1, 8.12.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade undici to 7.30.1; undici to 8.12.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmundici | Affected
| Fixed in
|
| npmundici | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade undici to version 7.30.1 or 8.12.2 where this issue is fixed. Until upgrading, avoid composing the decompress interceptor with response handlers that throw exceptions during response processing, such as the dump interceptor with a maxSize limit.
Description
A vulnerability in undici's decompress interceptor allows a denial of service via an unhandled exception. When the decompress interceptor forwards decompressed data to a downstream handler that throws an exception asynchronously (such as the dump interceptor with a maxSize limit), the exception is uncaught and terminates the Node.js process. This can be triggered by a malicious HTTP server sending a small compressed response that decompresses to a size exceeding the limit. The issue affects undici versions >=7.15.0 <7.30.1 and >=8.0.0 <8.12.2. Fixed in versions 7.30.1 and 8.12.2.
References
- github.com/nodejs/undici/security/advisories/GHSA-55wc-3pg8-jfw6 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-87029 (opens in a new tab)
- github.com/nodejs/undici/commit/63cba7712ca012b2603c6aeeb4c72d8692332cd0 (opens in a new tab)
- github.com/nodejs/undici/commit/f851f315db1f2acce0ea668f88d9d0fa61c8420c (opens in a new tab)
- cna.openjsf.org/security-advisories.html (opens in a new tab)
- github.com/nodejs/undici (opens in a new tab)
- github.com/nodejs/undici/releases/tag/v7.30.1 (opens in a new tab)
- github.com/nodejs/undici/releases/tag/v8.12.2 (opens in a new tab)